Here is a patch with some changes:
http://frikod.se/~capitol/StringBufferAndVariableBoxingCleanup.patch
It's a bit to large to be really usable in my opinion, but there is also a commit history here:
https://github.com/alexanderkjall/kolmafia/commits/master
I split the commits to one commit per file, in hindsight that might not have been the best way to do it, if i would make something like this again i think it would have been better to group the commits based on the type of change that was done.
The changes can be broken down into the following categories:
*) StringBuffer changed to StringBuilder, and calls to append chained instead of doing string concatination:
Discussed above, strictly due to performance reasons.
*) use .contains() instead of .indexOf()
Also discussed above, done because of readability.
*) removed the final qualifier on private methods
This is also a readability change, as private methods can't be overridden the final keyword doesn't have any effect. People sometimes say that it affects performance, but according to these sources:
http://www.ibm.com/developerworks/java/library/j-jtp04223/index.html#N100A7 and
http://www.ibm.com/developerworks/java/library/j-jtp1029/index.html .
*) removed variable boxing and unboxing
There is some calls to .intValue() on Integers and wraping of int with new Integer(someInt), these are redundant as java handles these conversions transparently.
*) strings compared with "" instead of using equals
These might indicate bugs, but most likely not, but it's a bif of an unsafe coding practice to compare strings using the != operator.
*) restructured imports
These was done by my editor and i didn't notice at first, so it became a bit hard to revert. Feel free to ignore and not import

(but it removed about 4k lines of imports

)
*) Added generics to avoid some casts
Here are these changesets
https://github.com/alexanderkjall/kolmafia/commit/74fd30dbd8800b80eb7009d8715f68242cd20f63
https://github.com/alexanderkjall/kolmafia/commit/4f480a1df3276d6a2d6d88821c9f9799e90ea631
https://github.com/alexanderkjall/kolmafia/commit/37699c5d7253f27198046263767afa74e3003991
This avoids some casts and makes the code a bit easier to read in my opinion.
I'll start trying to make some improvements to the chat that i have been thinking about, if i manage to improve something i'll submit another patch
